Resolved
This issue has been resolved. Widgets are now correctly loading the production version of projects as expected.
Investigating
Chat widgets may be loading the development version of a project instead of the production version, even when the version ID is set to production. Our team is actively investigating.